summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2012-11-16 18:00:09 +0100
committerTorbjorn Granlund <tege@gmplib.org>2012-11-16 18:00:09 +0100
commita5ed28b7744e6869e802fc8882d7eb128ae92b91 (patch)
treeb529cc90d0aadab31caa4d657da2bb439d4fdf61 /configure.in
parentbb683dd9f6d78f181e1da86b8125584d918be337 (diff)
downloadgmp-a5ed28b7744e6869e802fc8882d7eb128ae92b91.tar.gz
Add side-channel silent mpn division.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3d2d37257..34c85f656 100644
--- a/configure.in
+++ b/configure.in
@@ -2681,6 +2681,7 @@ gmp_mpn_functions="$extra_functions \
mu_bdiv_q mu_bdiv_qr \
bdiv_q bdiv_qr broot brootinv bsqrt bsqrtinv \
divexact bdiv_dbm1c redc_1 redc_2 redc_n powm powlo powm_sec \
+ sb_div_qr_sec sb_div_r_sec sbpi1_div_qr_sec sbpi1_div_r_sec \
trialdiv remove \
and_n andn_n nand_n ior_n iorn_n nior_n xor_n xnor_n \
copyi copyd zero tabselect \
@@ -2724,6 +2725,10 @@ case $tmp_fn in
tmp_mulfunc="aorrlsh_n sorrlsh_n";;
rsh1add_n|rsh1sub_n)
tmp_mulfunc="rsh1aors_n";;
+ sb_div_qr_sec|sb_div_r_sec)
+ tmp_mulfunc="sb_div_sec";;
+ sbpi1_div_qr_sec|sbpi1_div_r_sec)
+ tmp_mulfunc="sbpi1_div_sec";;
esac
])