summaryrefslogtreecommitdiff
path: root/tests/mpz/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-12-21 18:40:34 +0100
committerKevin Ryde <user42@zip.com.au>2001-12-21 18:40:34 +0100
commitfd665094f8e5d8286321fb28839239cec1bd3b50 (patch)
tree8b5c475847a6c5b334c9a9444d673bad98ed6eda /tests/mpz/Makefile.am
parent747a56b18688f7199ca48bf03ec0d8afa91a0967 (diff)
downloadgmp-fd665094f8e5d8286321fb28839239cec1bd3b50.tar.gz
* tests/mpz/t-io_raw.c: New file.
* tests/mpz/Makefile.am (check_PROGRAMS): Add it.
Diffstat (limited to 'tests/mpz/Makefile.am')
-rw-r--r--tests/mpz/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/tests/mpz/Makefile.am b/tests/mpz/Makefile.am
index abefe69c4..e858d6d7e 100644
--- a/tests/mpz/Makefile.am
+++ b/tests/mpz/Makefile.am
@@ -31,15 +31,16 @@ check_PROGRAMS = t-cmp t-mul t-mul_i t-tdiv t-tdiv_ui t-fdiv t-fdiv_ui t-gcd \
t-root t-perfsqr t-jac t-bin t-get_si t-set_si \
t-fac_ui t-fib_ui t-lucnum_ui t-scan t-fits \
t-divis t-divis_2exp t-cong t-cong_2exp t-sizeinbase t-set_str \
- t-aorsmul t-cmp_d t-cmp_si t-hamdist t-oddeven t-popcount t-set_f
+ t-aorsmul t-cmp_d t-cmp_si t-hamdist t-oddeven t-popcount t-set_f \
+ t-io_raw
TESTS = $(check_PROGRAMS)
-# io.tmp and t-inp_str.tmp are used by io.c and t-inp_str.c respectively,
-# both removed automatically if the tests pass, but arrange to clean them
-# here if the tests fail
+# io.tmp, t-io_raw.tmp and t-inp_str.tmp are used by io.c, t-io_raw.c and
+# t-inp_str.c respectively, all removed automatically if the tests pass, but
+# arrange to clean them here if the tests fail.
#
-CLEANFILES = io.tmp t-inp_str.tmp
+CLEANFILES = io.tmp t-io_raw.tmp t-inp_str.tmp
$(top_builddir)/tests/libtests.la:
cd $(top_builddir)/tests; $(MAKE) $(AM_MAKEFLAGS) libtests.la