summaryrefslogtreecommitdiff
path: root/tune/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2000-06-30 01:01:14 +0200
committerKevin Ryde <user42@zip.com.au>2000-06-30 01:01:14 +0200
commite49fe1b10732eff21fce752082ec1f8748f359f6 (patch)
tree26177ce9a836fa5577fb898a7c8bf97f869be051 /tune/Makefile.am
parente0ca29f3a84dfe6d34103247d237d8c74a62c7fd (diff)
downloadgmp-e49fe1b10732eff21fce752082ec1f8748f359f6.tar.gz
* tune/*: Locate data to help direct-mapped caches, add measuring
of mpz_init/clear, mpz_add and mpz_bin_uiui, various cleanups.
Diffstat (limited to 'tune/Makefile.am')
-rw-r--r--tune/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tune/Makefile.am b/tune/Makefile.am
index d8898f1c4..724549146 100644
--- a/tune/Makefile.am
+++ b/tune/Makefile.am
@@ -35,6 +35,11 @@ libspeed_la_LIBADD = $(libspeed_la_DEPENDENCIES)
# Both libspeed and the programs are built static-only since static is
# fastest and will be preferred by users who care about maximizing speed.
+#
+# Actually libtool doesn't seem to pass -static through to gcc, it only
+# chooses the ".a" versions of libtool libraries. Rerun the gcc link
+# invocation with -static if you want a static link of libc and libm.
+#
LDFLAGS = -static
LDADD = libspeed.la $(top_builddir)/libgmp.la -lm