summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 887975c40..6427ec3dd 100644
--- a/configure.in
+++ b/configure.in
@@ -919,7 +919,7 @@ case $host in
powerpc620) gcc_cflags_cpu="-mcpu=620" ;;
powerpc630) gcc_cflags_cpu="-mcpu=630"
xlc_cflags_arch="-qarch=pwr3"
- cpu_path="p3" ;;
+ cpu_path="p3 p3-p7" ;;
powerpc740) gcc_cflags_cpu="-mcpu=740" ;;
powerpc7400 | powerpc7410)
gcc_cflags_asm="-Wa,-maltivec"
@@ -935,19 +935,19 @@ case $host in
powerpc970) gcc_cflags_cpu="-mtune=970"
xlc_cflags_arch="-qarch=970 -qarch=pwr3"
vmx_path="powerpc64/vmx"
- cpu_path="p4" ;;
+ cpu_path="p4 p3-p7" ;;
power4) gcc_cflags_cpu="-mtune=power4"
xlc_cflags_arch="-qarch=pwr4"
- cpu_path="p4" ;;
+ cpu_path="p4 p3-p7" ;;
power5) gcc_cflags_cpu="-mtune=power5 -mtune=power4"
xlc_cflags_arch="-qarch=pwr5"
- cpu_path="p5 p4" ;;
+ cpu_path="p5 p4 p3-p7" ;;
power6) gcc_cflags_cpu="-mtune=power6"
xlc_cflags_arch="-qarch=pwr6"
- cpu_path="p6" ;;
+ cpu_path="p6 p3-p7" ;;
power7) gcc_cflags_cpu="-mtune=power7 -mtune=power5"
xlc_cflags_arch="-qarch=pwr7 -qarch=pwr5"
- cpu_path="p7 p5 p4" ;;
+ cpu_path="p7 p5 p4 p3-p7" ;;
esac
case $host in
@@ -1012,6 +1012,7 @@ case $host in
# incompatible with a shared library.
#
abilist="mode64 mode32 $abilist"
+ gcc_32_cflags_maybe="-m32"
gcc_cflags_opt="-O3 -O2 -O1" # will this become used?
cclist_mode32="gcc"
gcc_mode32_cflags_maybe="-m32"
@@ -1057,6 +1058,7 @@ case $host in
# 64-bits.
#
abilist="mode64 mode32 $abilist"
+ gcc_32_cflags_maybe="-m32"
cclist_mode32="gcc"
gcc_mode32_cflags_maybe="-m32"
gcc_mode32_cflags="-mpowerpc64"