summaryrefslogtreecommitdiff
path: root/plugins/power/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2022-03-22 17:05:55 +0100
committerBenjamin Berg <bberg@redhat.com>2022-03-23 15:39:20 +0100
commit96aeac57d6f76f672cbf9d3f20211a5cefe1885d (patch)
tree742b5aec9cc516ede3018649e793e3ceb601d979 /plugins/power/meson.build
parent5671b3c3b5e00d45f6462b657f6dc83bdcb01763 (diff)
downloadgnome-settings-daemon-96aeac57d6f76f672cbf9d3f20211a5cefe1885d.tar.gz
power: Remove backlight helperbenzea/brightness
Lets just assume that everyone has systemd-logind or elogind these days.
Diffstat (limited to 'plugins/power/meson.build')
-rw-r--r--plugins/power/meson.build35
1 files changed, 0 insertions, 35 deletions
diff --git a/plugins/power/meson.build b/plugins/power/meson.build
index 014bb6da..146137ab 100644
--- a/plugins/power/meson.build
+++ b/plugins/power/meson.build
@@ -66,41 +66,6 @@ gsd_power_enums_update = executable(
native: true
)
-if host_is_linux
- policy = 'org.gnome.settings-daemon.plugins.power.policy'
-
- policy_in = configure_file(
- input: policy + '.in.in',
- output: policy + '.in',
- configuration: plugins_conf
- )
-
- i18n.merge_file(
- input: policy_in,
- output: policy,
- po_dir: po_dir,
- install: true,
- install_dir: join_paths(gsd_datadir, 'polkit-1', 'actions')
- )
-
- sources = files(
- 'gsd-backlight-helper.c',
- )
-
- deps = [
- ]
-
- executable(
- 'gsd-backlight-helper',
- sources,
- include_directories: top_inc,
- dependencies: deps,
- install: true,
- install_rpath: gsd_pkglibdir,
- install_dir: gsd_libexecdir
- )
-endif
-
output = 'gsdpowerconstants.py'
gsdpowerconstants_py = custom_target(