summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2014-08-12 14:30:54 +0200
committerAlexander Larsson <alexl@redhat.com>2014-08-12 14:59:01 +0200
commitc9c23f529e888c0642507591357afdf8f47bad0b (patch)
tree4cda9f8b1a5e4669a5b112a4b7dde128c086e970 /configure.ac
parent08db17255cbaae3a81896f36ff8ba917cdb311e4 (diff)
downloadadwaita-icon-theme-c9c23f529e888c0642507591357afdf8f47bad0b.tar.gz
Fix installation of symbolic pngs
This adds 24 px symbolic pngs allowing the small size and better hidpi handling (which uses the double size icon). It also ensures we have directories for the 64 & 96 size symbolic pngs in the index.theme file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bd0b7062d..2beff0796 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,7 @@ AC_SUBST(SVGSRCDIR, "src/symbolic")
# Icon sizes we want to install
AC_SUBST([render_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 256x256"])
AC_SUBST([symbolic_render_sizes], [""])
+AC_SUBST([install_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 64x64 96x96 256x256"])
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache)
if test -z "$GTK_UPDATE_ICON_CACHE"; then
@@ -51,7 +52,7 @@ if test "x$INKSCAPE" = "xfalse"; then
fi
AM_CONDITIONAL(ALLOW_RENDERING, test "x$allow_rendering" = "xyes")
-symbolic_encode_sizes="16x16 32x32 48x48 64x64 96x96"
+symbolic_encode_sizes="16x16 24x24 32x32 48x48 64x64 96x96"
AC_PATH_PROG([GTK_ENCODE_SYMBOLIC_SVG], [gtk-encode-symbolic-svg], [false])
if test "x$GTK_ENCODE_SYMBOLIC_SVG" = "xfalse"; then
symbolic_encode_sizes=""