summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-05-28 11:20:41 -0400
committerMatthias Clasen <mclasen@redhat.com>2014-05-28 11:29:40 -0400
commit52330b92bb069c073e4f31577499745480ee973f (patch)
tree21a258d9d4b6a156161fc9f28bc75059a3809747 /configure.ac
parent8e0fe6f68313651df257b021d68eadd894353306 (diff)
downloadadwaita-icon-theme-52330b92bb069c073e4f31577499745480ee973f.tar.gz
Drop legacy icon name mapping
The switch gnome -> Adwaita is the perfect opportunity to do this cleanup. Also, the icon name mapping tool doesn't work. https://bugzilla.gnome.org/show_bug.cgi?id=728984
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index b9e2a8b22..1636fd15f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,35 +30,6 @@ AC_SUBST(SVGSRCDIR, "src/symbolic")
AC_SUBST([render_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 256x256"])
AC_SUBST([symbolic_render_sizes], [""])
-# Allow icon mapping to be disabled
-AC_ARG_ENABLE([icon-mapping],
- AC_HELP_STRING([--enable-icon-mapping],
- [Enable compatibility symlinks [default=auto]]),
- [enable_mapping=$enableval],
- [enable_mapping=yes])
-
-ICONMAP="true"
-if test "x$enable_mapping" != "xno"; then
- UTILS_REQUIRED=0.8.7
-
- AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
- PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
- have_utils=yes, have_utils=no)
- if test "x$have_utils" = "xyes"; then
- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
- ICONMAP="$UTILS_PATH/icon-name-mapping"
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
- and install adwaita-icon-theme])
- fi
-else
- ICONMAP="false"
-fi
-
-AC_SUBST(ICONMAP)
-
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache)
if test -z "$GTK_UPDATE_ICON_CACHE"; then
AC_MSG_ERROR([Could not find gtk-update-icon-cache])