summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2015-05-16 07:49:19 +0000
committerJakub Steiner <jimmac@gmail.com>2015-05-18 16:19:23 +0200
commite22e0540ea8d67f0844046dc10e855ea64686a2e (patch)
treea9297cb075d2ecd76ad92d83e06fea54d3bb1c7b /configure.ac
parent9eae7cb6c2820e3de8ea090b169195699e3cdf05 (diff)
downloadadwaita-icon-theme-e22e0540ea8d67f0844046dc10e855ea64686a2e.tar.gz
Create symlinks when installing cursors
Also support creating symlinks for W32 cursors (including L and XL variants). https://bugzilla.gnome.org/show_bug.cgi?id=749223
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e4d8a0fa..312b24c1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,7 @@ AC_SUBST([render_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 256x256"])
AC_SUBST([symbolic_render_sizes], [""])
AC_SUBST([install_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 64x64 96x96 256x256"])
+AC_PROG_LN_S
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache)
# need git, icontool, and inkscape for rendering
@@ -56,6 +57,29 @@ if test "x$GTK_ENCODE_SYMBOLIC_SVG" = "xfalse"; then
fi
AC_SUBST(symbolic_encode_sizes)
+AC_ARG_ENABLE([w32-cursors],
+ [AS_HELP_STRING([--enable-w32-cursors],
+ [Make and install Windows cursors (.cur and .ani) instead of X cursors])],
+ [case "${enableval}" in
+ yes) enable_w32_cursors=yes ;;
+ no) enable_w32_cursors=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-w32-cursors]) ;;
+ esac],
+ [enable_w32_cursors=no])
+AC_SUBST(enable_w32_cursors)
+
+AC_ARG_ENABLE([l-xl-variants],
+ [AS_HELP_STRING([--enable-l-xl-variants],
+ [Also make and install Large and Extra Large Windows cursor versions])],
+ [case "${enableval}" in
+ yes) enable_l_xl_variants=yes ;;
+ no) enable_l_xl_variants=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-l-xl-variants]) ;;
+ esac],
+ [enable_l_xl_variants=no])
+AC_SUBST(enable_l_xl_variants)
+AM_CONDITIONAL([ENABLE_L_XL_VARIANTS], [test x$enable_l_xl_variants = xyes])
+
AC_CONFIG_FILES([
Makefile
adwaita-icon-theme.pc