summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2015-08-26 22:41:24 +0100
committerLionel Landwerlin <llandwerlin@gmail.com>2015-09-12 00:51:51 +0200
commitf53e60361a1cb37b6653ca6bf4fc77d4baa2d73d (patch)
treefd056b6bb2bca3bb9bb5d7f7ec7ba23be4825aba /configure.ac
parent2a7e58a8b9f92bd5e23c71f8fb87c545c951bc72 (diff)
downloadclutter-gtk-f53e60361a1cb37b6653ca6bf4fc77d4baa2d73d.tar.gz
embed: rework foreign stage setup to work on gdk/wayland
On hide/unmap the GDK wayland backend might decide to destroy its wayland surface [1]. There is no event notifying Clutter/Cogl of this. We need to notify Clutter/Cogl that the surface has changed when the embed widget becomes visible/invisible. So instead of mapping the different mapped/visible/realized properties of the GtkWidget to the ClutterStage, we take a different approach by considering that an invisible GtkWidget means an unrealized ClutterStage. [1] : https://git.gnome.org/browse/gtk+/commit/?id=87e2a7d4b23e633d0f2263d6ebd205c113eede0f https://bugzilla.gnome.org/show_bug.cgi?id=754891
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7f2c21e..60eb29e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,7 @@ AC_HEADER_STDC
AC_CHECK_LIBM
AC_SUBST(LIBM)
-m4_define([clutter_req_version], [1.22.3])
+m4_define([clutter_req_version], [1.23.7])
m4_define([gtk_req_version], [3.6.0])
PKG_CHECK_MODULES([CLUTTER_GTK_DEPS], [clutter-1.0 >= clutter_req_version gtk+-3.0 >= gtk_req_version])