summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@openedhand.com>2007-08-19 17:06:22 +0000
committerEmmanuele Bassi <ebassi@openedhand.com>2007-08-19 17:06:22 +0000
commit1a6deea7a7eb9e954d692cb948f81d76dd2e8483 (patch)
treeb290c7a0d9c7fe8aa6664bf174e0cc1edac70203 /tests/Makefile.am
parent5b3f06faacdfa174ebe630932d76fb9768688d91 (diff)
downloadclutter-1a6deea7a7eb9e954d692cb948f81d76dd2e8483.tar.gz
Use g_list_insert_sorted() instead of our custom function
The clutter_timeout_pool_insert_sorted() function caused an inversion of the timeout sources in the pool; this led to a wrong behaviour in the execution of the timeout functions. See bug 471. This patch drops clutter_timeout_pool_insert_sorted() in favour of the standard g_list_insert_sorted(), which produces identical behaviours with and without the pool. A new test, written by Rob Bradford, has been added to the regression test suite in order to identify sorting issues with the timeout pools.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3855f4dc8..8f82da967 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,7 @@
noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
test-actors test-behave test-text test-entry test-project \
test-boxes test-perspective test-rotate test-depth \
- test-threads
+ test-threads test-timeline
INCLUDES = -I$(top_srcdir)/
LDADD = $(top_builddir)/clutter/libclutter-@CLUTTER_FLAVOUR@-@CLUTTER_MAJORMINOR@.la
@@ -22,5 +22,6 @@ test_perspective_SOURCES = test-perspective.c
test_rotate_SOURCES = test-rotate.c
test_depth_SOURCES = test-depth.c
test_threads_SOURCES = test-threads.c
+test_timeline_SOURCES = test-timeline.c
EXTRA_DIST = redhand.png