summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@openedhand.com>2008-09-12 10:31:44 +0000
committerNeil Roberts <neil@openedhand.com>2008-09-12 10:31:44 +0000
commitb16e75db2c51ffddfdcb3ba43aa8f7bf85997904 (patch)
tree19517d17ba68371d291616167e06c7243850203c /tests/Makefile.am
parentb83470366c18149796fc6f682bab2aa100d8c561 (diff)
downloadclutter-b16e75db2c51ffddfdcb3ba43aa8f7bf85997904.tar.gz
Bug 1010 - ClutterLabel does not update the layout (again)
* clutter/clutter-label.c: Bring back layout caching. This time it will cache up to three different layouts. The width for which each layout was generated is stored so that if the same width is requested again it can use the cached version. If no cached version is available it will try to replace the oldest layout. 'Age' is determined by a counter which is incremented every time a layout is created. The cache is cleared after any property changes that might affect the layout. (struct _ClutterLabelPrivate): Removed extents_width, extents_height and context because they weren't used anywhere. * tests/test-label-cache.c: Add a test which checks whether the label is using a different layout when properties are changed. Also compares the extents of the label's layout with an independent layout and fails if they aren't the same. * tests/Makefile.am (noinst_PROGRAMS): Add test-label-cache
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a8ca07444..d6a75336c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,7 @@ noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
test-cogl-tex-polygon test-stage-read-pixels \
test-random-text test-clip test-paint-wrapper \
test-texture-quality test-entry-auto test-layout \
- test-invariants
+ test-invariants test-label-cache
if X11_TESTS
noinst_PROGRAMS += test-pixmap
@@ -72,5 +72,6 @@ test_entry_auto_SOURCES = test-entry-auto.c
test_layout_SOURCES = test-layout.c
test_invariants_SOURCES = test-invariants.c
test_devices_SOURCES = test-devices.c
+test_label_cache_SOURCES = test-label-cache.c
EXTRA_DIST = redhand.png test-script.json