summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@redhat.com>2009-05-13 23:14:24 +0100
committerEmmanuele Bassi <ebassi@linux.intel.com>2009-05-13 23:31:43 +0100
commit38f6fb70acc14252b026230f7e760c49d0ff410f (patch)
tree13628d0e6e4cc79e764fd3d81184238d863dd20d /Makefile.am
parentaeb1516a89ba04b7900de66a19de2ad7505000db (diff)
downloadcogl-38f6fb70acc14252b026230f7e760c49d0ff410f.tar.gz
Don't build Cogl.gir against installed Clutter library
Passing: --library=clutter-@CLUTTER_FLAVOUR@-@CLUTTER_API_VERSION@ to g-ir-scanner, when building Cogl was causing g-ir-scanner to link the introspection program against the installed clutter library, if it existed or fail otherwise. Instead copy the handling from the json/ directory where we link against the convenience library to scan, and do the generation of the typelib later in the main clutter/directory. Fixes bug: http://bugzilla.openedhand.com/show_bug.cgi?id=1594 Signed-off-by: Emmanuele Bassi <ebassi@linux.intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 11 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 4435e8c6..10ae2448 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,6 @@ CLEANFILES = $(pc_files)
AM_CPPFLAGS = $(CLUTTER_CFLAGS) $(CLUTTER_DEBUG_CFLAGS) $(MAINTAINER_CFLAGS)
if HAVE_INTROSPECTION
-
cogl_headers = \
$(top_srcdir)/clutter/cogl/cogl-bitmap.h \
$(top_srcdir)/clutter/cogl/cogl-color.h \
@@ -39,6 +38,13 @@ cogl_headers = \
$(top_srcdir)/clutter/cogl/cogl-types.h \
$(top_srcdir)/clutter/cogl/cogl-vertex-buffer.h
+# HACK - gobject-introspection can't scan a library in another directory
+# so we create a libclutter-cogl.la that's just identical to the one
+# in the subdir
+noinst_LTLIBRARIES = libclutter-cogl.la
+libclutter_cogl_la_LIBADD = $(CLUTTER_COGL)/libclutter-cogl.la
+libclutter_cogl_la_SOURCES = $(cogl_headers)
+
Cogl-@CLUTTER_API_VERSION@.gir: $(INTROSPECTION_SCANNER) $(CLUTTER_COGL)/libclutter-cogl.la
$(QUIET_GEN)$(INTROSPECTION_SCANNER) -v \
--namespace Cogl --nsversion=@CLUTTER_API_VERSION@ \
@@ -49,7 +55,7 @@ Cogl-@CLUTTER_API_VERSION@.gir: $(INTROSPECTION_SCANNER) $(CLUTTER_COGL)/libclut
-DCLUTTER_COMPILATION \
--include=GL-1.0 \
--include=GObject-2.0 \
- --library=clutter-@CLUTTER_FLAVOUR@-@CLUTTER_API_VERSION@ \
+ --library=clutter-cogl \
--libtool="$(top_builddir)/doltlibtool" \
--pkg gobject-2.0 \
--output $@ \
@@ -59,21 +65,8 @@ Cogl-@CLUTTER_API_VERSION@.gir: $(INTROSPECTION_SCANNER) $(CLUTTER_COGL)/libclut
BUILT_GIRSOURCES = Cogl-@CLUTTER_API_VERSION@.gir
-#girdir = $(datadir)/gir-1.0
-#gir_DATA = $(BUILT_GIRSOURCES)
-
-#typelibsdir = $(libdir)/girepository-1.0
-#typelibs_DATA = Cogl-@CLUTTER_API_VERSION@.typelib
-
-#%.typelib: %.gir $(INTROSPECTION_COMPILER)
-# $(QUIET_GEN)$(DEBUG) $(INTROSPECTION_COMPILER) \
-# --includedir=$(top_builddir)/clutter \
-# --includedir=$(top_srcdir)/clutter \
-# --includedir=$(srcdir) \
-# --includedir=. \
-# $(INTROSPECTION_COMPILER_OPTS) \
-# $< -o $(@F)
-
-CLEANFILES += $(BUILT_GIRSOURCES) #$(typelibs_DATA)
+girdir = $(datadir)/gir-1.0
+gir_DATA = $(BUILT_GIRSOURCES)
+CLEANFILES += $(BUILT_GIRSOURCES)
endif