summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2011-05-05 21:39:40 +0100
committerRobert Bragg <robert@linux.intel.com>2011-05-06 12:12:03 +0100
commit4211462eb246aa423496a84b36a27605111bf0eb (patch)
tree8d02741b0d887ebd4aaefd15de3a5c8fcf388d71 /Makefile.am
parentb6ebbc366e5570366a6037fc47ff727672cb9fe9 (diff)
downloadcogl-4211462eb246aa423496a84b36a27605111bf0eb.tar.gz
Make building cogl-pango optional
When building for platforms that don't use pango for handling text you may not need the cogl-pango library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d7dd3eb..a3c2b814 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,8 @@
-SUBDIRS = cogl pango
+SUBDIRS = cogl
+
+if BUILD_COGL_PANGO
+SUBDIRS += pango
+endif
if COGL_STANDALONE_BUILD
SUBDIRS += po examples