summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2013-04-28 02:42:24 +0100
committerRobert Bragg <robert@linux.intel.com>2013-05-29 19:30:44 +0100
commit0e7a632e139611b63b188d9a4a3a49e296d93ea3 (patch)
tree1d96f426d6d6b0c4c2b0cc86698e9b5e26201441 /cogl/Makefile.am
parentd39f4b8a16a4ddd57f2f2ceb5bf98c776de76bbe (diff)
downloadcogl-0e7a632e139611b63b188d9a4a3a49e296d93ea3.tar.gz
Adds initial Emscripten support to Cogl
This enables basic Emscripten support in Cogl via the SDL winsys. Assuming you have setup an emscripten toolchain you can configure Cogl like this: emconfigure ./configure --enable-debug --enable-emscripten Building the examples will build .html files that can be loaded directly by a WebGL enabled browser. Note: at this point the emscripten support has just barely been smoke tested so it's expected that as we continue to build on this we will learn about more things we need to change in Cogl to full support this environment. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit a3bc2e7539391b074e697839dfae60b69c37cf10)
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index 4a65ce28..9622c1c4 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -258,6 +258,7 @@ cogl_sources_c = \
$(cogl_winsys_common_sources) \
$(cogl_tesselator_sources) \
$(srcdir)/cogl-private.h \
+ $(srcdir)/cogl-i18n-private.h \
$(srcdir)/cogl-debug.h \
$(srcdir)/cogl-debug-options.h \
$(srcdir)/cogl-gpu-info.c \