summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-09-17 02:20:10 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-22 17:47:58 +0000
commitd2c41502a4e74e50968cce11d908e6a74ed2357d (patch)
tree10fb722a0ae1109365457d10a926c71188406fd1 /cogl/Makefile.am
parentdf21e20f65482b9f52a2e8ccabb2b0d71ee65e07 (diff)
downloadcogl-d2c41502a4e74e50968cce11d908e6a74ed2357d.tar.gz
build: Allow to build cogl without an external glib dependency
This commit pushes --disable-glib to the extreme of embedding the par of glib cogl depends on in tree to be able to generate a DSO that does not depend on an external glib. To do so, it: - keeps a lot of glib's configure.ac in as-glibconfig.m4 - pulls the code cogl depends on and the necessary dependencies Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index 1770a822..4212e6fe 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -18,6 +18,7 @@ lib_LTLIBRARIES =
INCLUDES = \
-I$(top_srcdir) \
-I$(top_builddir) \
+ -I$(top_builddir)/deps/glib \
-I$(srcdir)/tesselator \
-I$(srcdir)/winsys \
-I$(srcdir)/driver/gl \
@@ -515,6 +516,10 @@ libcogl_la_LIBADD = -lm $(COGL_DEP_LIBS) $(COGL_EXTRA_LDFLAGS)
if SUPPORT_GLX
libcogl_la_LIBADD += -ldl
endif
+if !USE_GLIB
+libcogl_la_LIBADD += $(top_builddir)/deps/glib/libglib.la
+libcogl_la_LIBADD += $(top_builddir)/deps/gmodule/libgmodule.la
+endif
# XXX: The aim is to eventually get rid of all private API exports
# for cogl-pango.
libcogl_la_LDFLAGS = \