summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2013-06-08 01:58:05 +0100
committerNeil Roberts <neil@linux.intel.com>2013-07-29 16:38:53 +0100
commitfc5d1a8a680b9cb78e9ffb18ff0822ac64177142 (patch)
tree23ad27a6747f78e84beb30153a134a2037735c5a /cogl/Makefile.am
parent6f480c7530fc1c3f73676d3c3c19b2479d67ffff (diff)
downloadcogl-fc5d1a8a680b9cb78e9ffb18ff0822ac64177142.tar.gz
Expose CoglAtlasTexture api
This exposes the CoglAtlasTexture api, making the following public: cogl_atlas_texture_new_with_size cogl_atlas_texture_new_from_file cogl_atlas_texture_new_from_data cogl_atlas_texture_new_from_bitmap The plan is to remove auto-texture apis like cogl_texture_new_from_file since they are a bit too magic, but that means we need an explicit way for users to allocate texture that will go in the atlas. Although the _new_from_file() api is arguably redundant since you can use _bitmap_new_from_file() followed by _atlas_texture_new_from_bitmap() we don't want to loose any of the convenience that cogl_texture_new_from_file() had. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit fe515e6063ba4c3ddb5cd00d2c8527d9a6336a12) Conflicts: cogl/Makefile.am
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index 0183c1b2..0ea41c7e 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -125,6 +125,7 @@ cogl_experimental_h = \
$(srcdir)/cogl-texture-rectangle.h \
$(srcdir)/cogl-texture-2d-sliced.h \
$(srcdir)/cogl-sub-texture.h \
+ $(srcdir)/cogl-atlas-texture.h \
$(srcdir)/cogl-meta-texture.h \
$(srcdir)/cogl-primitive-texture.h \
$(srcdir)/cogl-depth-state.h \
@@ -577,7 +578,7 @@ libcogl_la_LDFLAGS = \
-no-undefined \
-version-info @COGL_LT_CURRENT@:@COGL_LT_REVISION@:@COGL_LT_AGE@ \
-export-dynamic \
- -export-symbols-regex "^(cogl|_cogl_debug_flags|_cogl_atlas_new|_cogl_atlas_add_reorganize_callback|_cogl_atlas_reserve_space|_cogl_callback|_cogl_util_get_eye_planes_for_screen_poly|_cogl_atlas_texture_remove_reorganize_callback|_cogl_atlas_texture_add_reorganize_callback|_cogl_texture_foreach_sub_texture_in_region|_cogl_atlas_texture_new_with_size|_cogl_profile_trace_message|_cogl_context_get_default|test_|unit_test_).*"
+ -export-symbols-regex "^(cogl|_cogl_debug_flags|_cogl_atlas_new|_cogl_atlas_add_reorganize_callback|_cogl_atlas_reserve_space|_cogl_callback|_cogl_util_get_eye_planes_for_screen_poly|_cogl_atlas_texture_remove_reorganize_callback|_cogl_atlas_texture_add_reorganize_callback|_cogl_texture_foreach_sub_texture_in_region|_cogl_profile_trace_message|_cogl_context_get_default|test_|unit_test_).*"
libcogl_la_SOURCES = $(cogl_sources_c)
nodist_libcogl_la_SOURCES = $(BUILT_SOURCES)