summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-11-08 20:33:00 +0000
committerRobert Bragg <robert@linux.intel.com>2013-01-21 14:20:32 +0000
commit2adfe6d80577e12f817c85026fb699b2859b82ec (patch)
treede18497fac2db18e90c336133bcced587a206b87 /cogl/Makefile.am
parent63e0c1eac62a30729cf86c2c4b558b24764f3995 (diff)
downloadcogl-2adfe6d80577e12f817c85026fb699b2859b82ec.tar.gz
texture: split out high-level texture constructors
This splits out the very high level texture constructors that may internally construct one of several types of lower level texture due to various constraints. This also updates the prototypes for these constructors to take an explicit context pointer and return a CoglError consistent with other texture constructors. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit a1cabfae6ad50c51006c608cdde7d631b7832e71)
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index 9a75eb70..e53392cc 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -361,6 +361,7 @@ cogl_sources_c = \
$(srcdir)/cogl-texture-driver.h \
$(srcdir)/cogl-sub-texture.c \
$(srcdir)/cogl-texture.c \
+ $(srcdir)/cogl-auto-texture.c \
$(srcdir)/cogl-texture-2d.c \
$(srcdir)/cogl-texture-2d-sliced.c \
$(srcdir)/cogl-texture-3d.c \