summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-09-24 16:42:44 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-20 18:38:22 +0000
commit6a0f4bb7875526731e9e10aac35962a29bb93da7 (patch)
tree19f4d31c0e919e930133b6f94f10a17f549c9f78 /cogl/Makefile.am
parent28a8d5b91f1cbc929abfdd77894235ee782857fd (diff)
downloadcogl-6a0f4bb7875526731e9e10aac35962a29bb93da7.tar.gz
build: don't include deps/glib headers if glib enabled
If we're using the system glib library then we need to make sure not to include headers under deps/glib otherwise we end up with with incompatible typedefs that break the build. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 5d5fc97b59951ec56a4193b7ee7909ebd3cfbb94)
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index 1fc35380..604f7aa5 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -18,7 +18,6 @@ lib_LTLIBRARIES =
INCLUDES = \
-I$(top_srcdir) \
-I$(top_builddir) \
- -I$(top_builddir)/deps/glib \
-I$(srcdir)/tesselator \
-I$(srcdir)/winsys \
-I$(srcdir)/driver/gl \
@@ -26,6 +25,10 @@ INCLUDES = \
-I$(srcdir)/driver/gl/gles \
$(NULL)
+if !USE_GLIB
+ INCLUDES += -I$(top_builddir)/deps/glib
+endif
+
AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"Cogl\" \
-DCOGL_COMPILATION \