summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-09-12 22:39:46 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-20 18:38:22 +0000
commit7df425163741ed9c9e4c1995da20d68463c55599 (patch)
tree69501283706c4eee3c5f6cf3bbf8511f5d95e913 /cogl/Makefile.am
parent34618529b908ce64061e5acad8263764c9cbc039 (diff)
downloadcogl-7df425163741ed9c9e4c1995da20d68463c55599.tar.gz
Adds a NOP driver
This adds a new "nop" driver that does nothing. This can be selected at runtime either with the COGL_DRIVER=nop environment variable or by passing COGL_DRIVER_NOP to cogl_renderer_set_driver() Adding the nop driver gives us a way to test workloads without any driver and hardware overheads which can help us understand how Cogl's state tracking performs in isolation. Having a nop driver can also serve as an shell/outline for creating other drivers later. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 90587418233b6438290741d80aedf193ae660cad)
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index e43fc9eb..6e6a1b8b 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -136,6 +136,20 @@ cogl_experimental_h = \
cogl_nodist_experimental_h = \
$(NULL)
+# nop driver
+cogl_driver_sources = \
+ $(srcdir)/driver/nop/cogl-driver-nop-private.h \
+ $(srcdir)/driver/nop/cogl-driver-nop.c \
+ $(srcdir)/driver/nop/cogl-framebuffer-nop-private.h \
+ $(srcdir)/driver/nop/cogl-framebuffer-nop.c \
+ $(srcdir)/driver/nop/cogl-attribute-nop-private.h \
+ $(srcdir)/driver/nop/cogl-attribute-nop.c \
+ $(srcdir)/driver/nop/cogl-clip-stack-nop-private.h \
+ $(srcdir)/driver/nop/cogl-clip-stack-nop.c \
+ $(srcdir)/driver/nop/cogl-texture-2d-nop-private.h \
+ $(srcdir)/driver/nop/cogl-texture-2d-nop.c \
+ $(NULL)
+
# gl driver sources
cogl_gl_prototypes_h = \
$(srcdir)/gl-prototypes/cogl-gles2-functions.h \
@@ -145,8 +159,7 @@ cogl_gl_prototypes_h = \
$(srcdir)/gl-prototypes/cogl-glsl-functions.h \
$(NULL)
-# driver sources
-cogl_driver_sources = \
+cogl_driver_sources += \
$(srcdir)/driver/gl/cogl-framebuffer-gl.c \
$(srcdir)/driver/gl/cogl-texture-2d-gl-private.h \
$(srcdir)/driver/gl/cogl-texture-2d-gl.c \