summaryrefslogtreecommitdiff
path: root/cogl/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2011-09-27 15:32:58 +0100
committerNeil Roberts <neil@linux.intel.com>2011-09-27 16:08:42 +0100
commitc1602f4abcf9083fde25c8e576d019f30cf192fb (patch)
tree62296ff5b4538a79752a174599dc6d3624ed4262 /cogl/Makefile.am
parent7bd66f40ca3fa01ec49ebe2d87a76c26874bacd7 (diff)
downloadcogl-c1602f4abcf9083fde25c8e576d019f30cf192fb.tar.gz
cogl-journal: Use a loose region instead of a bounding boxwip/journal-reorg
Instead of just recording the bounding box of a journal batch, it now uses a new data type called a loose region. A loose region keeps track of up to 4 separate bounding boxes to represent at least the region covered by the batch. If a new rectangle added to the region only increases the size of an existing bounding box to within a certain threshold then it will be added to that bounding box, otherwise it will start a new bounding box. This increases the chances that batches can be grouped together because it can represent sparse regions to a degree without as much of the complexity as totally accurately tracking the region.
Diffstat (limited to 'cogl/Makefile.am')
-rw-r--r--cogl/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cogl/Makefile.am b/cogl/Makefile.am
index f12354f5..7968a5ad 100644
--- a/cogl/Makefile.am
+++ b/cogl/Makefile.am
@@ -313,6 +313,8 @@ cogl_sources_c = \
$(srcdir)/cogl-gtype-private.h \
$(srcdir)/cogl-point-in-poly-private.h \
$(srcdir)/cogl-point-in-poly.c \
+ $(srcdir)/cogl-loose-region.h \
+ $(srcdir)/cogl-loose-region.c \
$(srcdir)/cogl-clutter.c \
$(srcdir)/winsys/cogl-winsys-stub-private.h \
$(srcdir)/cogl-queue.h \