summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2011-05-25 01:37:56 +0100
committerRobert Bragg <robert@linux.intel.com>2011-06-01 20:44:42 +0100
commita29a76dbabf8e68febc50288465fccdfd8d1313f (patch)
tree85d7c1773317ed3612dd4cbe62c39ad8d1c27c79 /configure.ac
parent8714d99300ff6da1fba7959278b321f5eea94844 (diff)
downloadcogl-a29a76dbabf8e68febc50288465fccdfd8d1313f.tar.gz
Adds _cogl_wayland_texture_2d_new_from_buffer API
This adds internal API to be able to wrap a wayland buffer as a CoglTexture2D. There is a --enable-wayland-egl-server option to decide if Cogl should support this feature and potentially any EGL based winsys could support this through the EGL_KHR_image_base and EGL_WL_bind_display extensions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a201d20..ad27450b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -614,6 +614,21 @@ AS_IF([test "x$enable_wayland_egl_platform" == "xyes"],
AM_CONDITIONAL(SUPPORT_EGL_PLATFORM_WAYLAND,
[test "x$enable_wayland_egl_platform" = "xyes"])
+AC_ARG_ENABLE(
+ [wayland-egl-server],
+ [AC_HELP_STRING([--enable-wayland-egl-server=@<:@no/yes@:>@], [Enable server side wayland support @<:@default=no@:>@])],
+ [],
+ enable_wayland_egl_server=no
+)
+AS_IF([test "x$enable_wayland_egl_server" == "xyes"],
+ [
+ NEED_EGL=yes
+ COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES wayland-server"
+ COGL_DEFINES_SYMBOLS="$COGL_DEFINES_SYMBOLS COGL_HAS_WAYLAND_EGL_SERVER_SUPPORT"
+ ])
+AM_CONDITIONAL(SUPPORT_WAYLAND_EGL_SERVER,
+ [test "x$enable_wayland_egl_server" = "xyes"])
+
dnl Android EGL platform
AC_ARG_ENABLE(
[android-egl-platform],
@@ -875,6 +890,7 @@ echo " Driver: ${COGL_DRIVER} ${glesversion}"
echo " GL Window System APIs:${GL_WINSYS_APIS}"
if test "x$SUPPORT_EGL" = "xyes"; then
echo " EGL Platforms:${EGL_PLATFORMS}"
+echo " Wayland compositor support: ${enable_wayland_egl_server}"
fi
echo " Image backend: ${COGL_IMAGE_BACKEND}"
echo " Cogl Pango: ${enable_cogl_pango}"