summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-09-17 21:58:55 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-22 17:47:58 +0000
commit41f443971ca18a909ab30f0e92bea2f4c0395a49 (patch)
tree20d4bd3622d3e6509fd8fe97e48e7ffc05978cbc /configure.ac
parentd2c41502a4e74e50968cce11d908e6a74ed2357d (diff)
downloadcogl-41f443971ca18a909ab30f0e92bea2f4c0395a49.tar.gz
Build: Add a --enable-standalone option
This option will generate a libcogl2 DSO that depends on the least possible external libraries. Reviewed-by: Robert Bragg <robert@linux.intel.com> (cherry picked from commit 6357960e1b91081546adf1bb110067d7db4d7400)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1e090f5..65653357 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,26 @@ dnl Handle extra configure options
dnl ================================================================
dnl ============================================================
+dnl Standalone cogl
+dnl ============================================================
+
+AC_ARG_ENABLE(
+ [standalone],
+ [AC_HELP_STRING([--enable-debug=@<:@no/yes@:>@], [Build Cogl without any external depedency @<:@default=no@:>@])],
+ [],
+ enable_standalone=no
+)
+AS_IF([test "x$enable_standalone" = "xyes"],
+ [
+ enable_cairo=no
+ enable_glib=no
+ enable_cogl_pango=no
+ enable_nls=no
+ enable_gdk_pixbuf=no
+ ]
+)
+
+dnl ============================================================
dnl Enable debugging
dnl ============================================================
m4_define([debug_default], [m4_if(cogl_release_status, [git], [yes], [no])])