summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Welche <prlw1@cam.ac.uk>2012-08-21 11:10:23 +0100
committerNeil Roberts <neil@linux.intel.com>2012-08-28 11:28:23 +0100
commit4589c6f15860522dbb256ffb298b395a2e1e421b (patch)
treeb58c4ea7c254c0e71181e6b7921fa8d5c050f033 /configure.ac
parent615e319384b3ae48ffd9afae04cff7adf8f43b52 (diff)
downloadcogl-4589c6f15860522dbb256ffb298b395a2e1e421b.tar.gz
test(1) uses '=' to test if strings are identical
https://bugzilla.gnome.org/show_bug.cgi?id=682340 Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 5cd15e7781466307a27c31e6e3f1e7f5ade5cfee)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 19177f82..78e5312b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -790,7 +790,7 @@ AC_ARG_ENABLE(
[],
enable_gdl_egl_platform=no
)
-AS_IF([test "x$enable_gdl_egl_platform" == "xyes"],
+AS_IF([test "x$enable_gdl_egl_platform" = "xyes"],
[
EGL_PLATFORM_COUNT=$((EGL_PLATFORM_COUNT+1))
NEED_EGL=yes
@@ -821,7 +821,7 @@ AC_ARG_ENABLE(
[],
enable_wayland_egl_platform=no
)
-AS_IF([test "x$enable_wayland_egl_platform" == "xyes"],
+AS_IF([test "x$enable_wayland_egl_platform" = "xyes"],
[
EGL_PLATFORM_COUNT=$((EGL_PLATFORM_COUNT+1))
NEED_EGL=yes
@@ -846,7 +846,7 @@ AC_ARG_ENABLE(
[],
enable_kms_egl_platform=no
)
-AS_IF([test "x$enable_kms_egl_platform" == "xyes"],
+AS_IF([test "x$enable_kms_egl_platform" = "xyes"],
[
EGL_PLATFORM_COUNT=$((EGL_PLATFORM_COUNT+1))
NEED_EGL=yes
@@ -870,7 +870,7 @@ AC_ARG_ENABLE(
[],
enable_wayland_egl_server=no
)
-AS_IF([test "x$enable_wayland_egl_server" == "xyes"],
+AS_IF([test "x$enable_wayland_egl_server" = "xyes"],
[
NEED_EGL=yes
COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES wayland-server"
@@ -886,7 +886,7 @@ AC_ARG_ENABLE(
[],
enable_android_egl_platform=no
)
-AS_IF([test "x$enable_android_egl_platform" == "xyes"],
+AS_IF([test "x$enable_android_egl_platform" = "xyes"],
[
EGL_PLATFORM_COUNT=$((EGL_PLATFORM_COUNT+1))
NEED_EGL=yes