summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-03-24 01:41:48 +0000
committerRobert Bragg <robert@linux.intel.com>2012-08-06 14:27:42 +0100
commit10340a5495b860f64f4dd8f9ed5b9928ae39b781 (patch)
tree3ded24ebf4e88d114e0b5a6c2d6e726bf76de959 /configure.ac
parent010d16f6479c90b66b7f90ab0341575b41555fca (diff)
downloadcogl-10340a5495b860f64f4dd8f9ed5b9928ae39b781.tar.gz
Adds libcogl-gles2 frontend GLES2 api
This adds a library that can be used instead of libGLESv2.so to provide symbols for the GLES 2.0 api. This can be used for convenience when using the cogl_gles2_context_ api since you don't need to manually go through a CoglGLES2Vtable when calling the gles2 api so it should be easier to port existing gles2 code to integrate with Cogl. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 80d7599a2acefca7d01d8d7de9df524278ef72c5)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 077772c1..3ed9b2fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -634,9 +634,30 @@ AC_SUBST([HAVE_GLES2])
if test "x$GL_LIBRARY_DIRECTLY_LINKED" = "xyes"; then
AC_DEFINE([HAVE_DIRECTLY_LINKED_GL_LIBRARY], [1],
- [Defined if the GL library shouldn't be dlopened])
+ [Defined if the GL library should not be dlopened])
fi
+AC_ARG_ENABLE(
+ [cogl-gles2],
+ [AC_HELP_STRING([--enable-cogl-gles2=@<:@no/yes@:>@],
+ [Enable libcogl-gles2 frontend api for OpenGL-ES 2.0 @<:@default=auto@:>@])],
+ [],
+ [
+ AS_IF([test "x$HAVE_GLES2" = "x1"],
+ [enable_cogl_gles2=yes],
+ [enable_cogl_gles2=no])
+ ]
+)
+AS_IF([test "x$enable_cogl_gles2" = "xyes"],
+ [
+ AS_IF([test "x$HAVE_GLES2" != "x1"],
+ [
+ AC_MSG_ERROR([libcogl-gles2 is currently only supported on systems with a native GLES 2.0 library])
+ ])
+ ])
+AM_CONDITIONAL([BUILD_COGL_GLES2], [test "x$enable_cogl_gles2" = "xyes"])
+
+
dnl ========================================================
dnl Check window system integration libraries...
dnl ========================================================
@@ -1155,6 +1176,8 @@ cogl-pango/Makefile
cogl-pango/cogl-pango-1.0.pc
cogl-pango/cogl-pango-2.0-experimental.pc
cogl-pango/cogl-pango.rc
+cogl-gles2/Makefile
+cogl-gles2/cogl-gles2-experimental.pc
doc/Makefile
doc/reference/Makefile
doc/reference/cogl/Makefile
@@ -1200,6 +1223,7 @@ fi
if test "x$SUPPORT_SDL" = "xyes"; then
echo " Support GLES under SDL: ${SUPPORT_SDL_GLES}"
fi
+echo " Build libcogl-gles2 GLES 2.0 frontend api: ${BUILD_COGL_GLES2}"
echo " Image backend: ${COGL_IMAGE_BACKEND}"
echo " Cogl Pango: ${enable_cogl_pango}"
echo " Profiling: ${enable_profile}"