summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-03-23 18:05:46 +0000
committerRobert Bragg <robert@linux.intel.com>2012-08-06 14:27:38 +0100
commit6400b455b88a4b0db05b7bb86e4f55e1c0a7763f (patch)
treeea05611f3daaf6bd885364636528df2308c22e26 /configure.ac
parente85a04f0cef4cf6591cf2ab5a626ffc120cce500 (diff)
downloadcogl-6400b455b88a4b0db05b7bb86e4f55e1c0a7763f.tar.gz
Don't include any GL header from the public GL headers
This splits the GL header inclusion from cogl-defines.h into a separate headear called cogl-gl-header.h which we will only include internally. That way we don't leak GL declarations out of our public headers. The texture functions that were using GLenum and GLuint in the public header have now changed to just use unsigned int. Note however that if an EGL winsys is enabled then it will still publicly include an EGL header. This is a bit more awkward to fix because we have public API which returns an EGLDisplay and we can't determine what type that is. There is also a conformance test which just verifies that no GL header has been included while compiling. The test isn't added to test-conform-main because it doesn't actually test anything at runtime. Reviewed-by: Robert Bragg <robert@linux.intel.com> (cherry picked from commit ef5680d3fda5df929dbd0b420c8f598ded58dfee)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 700cd2b6..3f0a992d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1120,6 +1120,7 @@ cogl/Makefile
cogl/cogl-1.0.pc
cogl/cogl-2.0-experimental.pc
cogl/cogl-defines.h
+cogl/cogl-gl-header.h
cogl/cogl.rc
cogl-pango/Makefile
cogl-pango/cogl-pango-1.0.pc