summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2013-04-05 18:08:29 +0100
committerNeil Roberts <neil@linux.intel.com>2013-04-23 17:46:55 +0100
commiteb5c92952e1882c95cfd6debc69a2c9efff096b9 (patch)
treeae2c6900f0cecb46e96bcf1d50026a578961896b /configure.ac
parente3cc008e7a26af462871448561e4cde0f95bfdf9 (diff)
downloadcogl-eb5c92952e1882c95cfd6debc69a2c9efff096b9.tar.gz
Fix a warning about ‘sincos’ in examples/cogl-gles2-gears
‘sincos’ is a GNU extension. cogl-gles2-gears was using it without defining _GNU_SOURCE so it was generating some annoying warnings. This patch fixes it by making the example include config.h which will end up defining _GNU_SOURCE. In addition this patch adds a configure check for the function and provides a fallback if it's not available. https://bugzilla.gnome.org/show_bug.cgi?id=697330 Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c188e6e..3c6d00bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1212,6 +1212,12 @@ AC_CHECK_FUNCS([ffs])
dnl 'memmem' is a GNU extension but we have a simple fallback
AC_CHECK_FUNCS([memmem])
+dnl This is used in the cogl-gles2-gears example but it is a GNU extension
+save_libs="$LIBS"
+LIBS="$LIBS $LIBM"
+AC_CHECK_FUNCS([sincos])
+LIBS="$save_libs"
+
dnl ================================================================
dnl Platform values
dnl ================================================================