summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2013-05-11 20:02:43 +0100
committerRobert Bragg <robert@linux.intel.com>2013-08-23 15:22:30 +0100
commit3fc1a39db886fe1e42362856c7708c70d74f787b (patch)
treef05a831b326974029f3f5dcbaacc3883d8ffe31c /configure.ac
parent34658ea05787201dd6caaa21fb60c2859fcd765b (diff)
downloadcogl-3fc1a39db886fe1e42362856c7708c70d74f787b.tar.gz
Adds "webgl" driver
This adds a COGL_DRIVER_WEBGL enum and a new driver description for webgl in cogl-renderer.c. This also adds a COGL_DRIVER_FLAG_OPENGL_WEB driver flag and a HAVE_COGL_WEBGL define which we can start to use to handle special cases where webgl differs from gles2. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 2c167b7a4ee56241827322bbe7cb287b0628437c)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5cf0cf41..91d3b2ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -731,6 +731,7 @@ AS_IF([test "x$enable_gles2" = "xyes"],
[
GL_LIBRARY_DIRECTLY_LINKED=yes
COGL_GLES2_LIBNAME=""
+ AC_DEFINE([HAVE_COGL_WEBGL], 1, [Have WebGL for rendering])
],
[