summaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index d8c2f03..14761b2 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -2,8 +2,12 @@ TESTS = tests.py
check_SCRIPTS = tests.py
-EXTRA_DIST = tests.py
+EXTRA_DIST = tests.py.in
+CLEANFILES = $(check_SCRIPTS)
+tests.py: tests.py.in
+ $(AM_V_GEN) sed -e 's|@PYTHON[@]|$(PYTHON)|g' $< > $@
+ chmod +x $@
# Default pep8.py --exclude + emacs backup files
PEP8_EXCLUDES=--exclude='.svn,CVS,.bzr,.hg,.git,__pycache__,.\#*'