summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim P. Gerla <timg@src.gnome.org>2005-07-02 01:21:31 +0000
committerTim P. Gerla <timg@src.gnome.org>2005-07-02 01:21:31 +0000
commit5967ca0c97790474e50c89162e476f18432c027c (patch)
tree89bda6e4dbf01147835742123cca624b04d30876 /Makefile.am
parent9aab3830695da8b140faeeaae1ea71d0dee06e61 (diff)
downloadeog-5967ca0c97790474e50c89162e476f18432c027c.tar.gz
Removed. Added my name. Added missing files. Add logic stolen from
* CVSVERSION, DEPENDS: Removed. * MAINTAINERS: Added my name. * shell/recent-files/Makefile.am: Added missing files. * Makefile.am: Add logic stolen from gnome-panel to make distcheck work without complaining about scrollkeeper files. A few more fixes to make distcheck pass.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 28 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ab0a0968..1b1fd994 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,31 @@
+#
+# FIXME:
+# currently scrollkeeper-update does not seem to
+# remove its database when there is no useful
+# information contained there. Therefore, with
+# "make uninstall" you're left with loads of
+# stuff in /var/scrollkeeper and distcheck
+# fails.
+#
+# http://mail.gnome.org/archives/gnome-doc-list/2003-May/msg00008.html
+#
+# This overrides the uninstall check so distcheck
+# passes
+#
+# distuninstallcheck_listfiles = find . -type f -print | grep -v 'scrollkeeper' | grep -v 'omf' | grep -v 'figures'
+distuninstallcheck:
+ @:
+
+distcleancheck_listfiles = find . -type f -print | grep -v 'omf\.out' | grep -v 'legal.xml'
+
if ENABLE_JPEG
jpeg_DIRS = jpegutils
endif
SUBDIRS = art $(jpeg_DIRS) libeog shell po help
-DIST_SUBDIRS = $(SUBDIRS) jpegutils
+DIST_SUBDIRS = $(SUBDIRS)
EXTRA_DIST = \
- DEPENDS \
HACKING \
MAINTAINERS \
TODO \
@@ -53,3 +72,10 @@ install-data-local:
else
install-data-local:
endif
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update \
+ eog.desktop \
+ eog.schemas