summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build30
1 files changed, 0 insertions, 30 deletions
diff --git a/src/meson.build b/src/meson.build
index df24c102..d9e45118 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -220,24 +220,6 @@ server_sources = app_sources + client_util_sources + debug_sources + dbus_source
'terminal-window.hh',
)
-if get_option('search_provider')
-
- server_sources += files(
- 'terminal-search-provider.cc',
- 'terminal-search-provider.hh',
- )
-
- server_sources += gnome.gdbus_codegen(
- 'terminal-search-provider-gdbus-generated',
- gt_prefix / gt_dbusinterfacedir / 'org.gnome.ShellSearchProvider2.xml',
- autocleanup: 'none',
- install_header: false,
- interface_prefix: 'org.gnome.Shell',
- namespace: 'Terminal',
- )
-
-endif
-
server_incs = [
top_inc,
src_inc,
@@ -293,18 +275,6 @@ configure_file(
install_dir: gt_prefix / gt_systemduserdir
)
-# Search provider
-
-if get_option('search_provider')
-
- provider_ini = files(gt_name + '-search-provider.ini')
-
- install_data(
- provider_ini,
- install_dir: gt_prefix / gt_searchproviderdir,
- )
-endif # option 'search_provider'
-
# Preferences
prefs_resources_sources = gnome.compile_resources(