summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1998-08-16 20:14:27 +0000
committerMartin Baulig <martin@src.gnome.org>1998-08-16 20:14:27 +0000
commit561becc92ef167760e3c13ad2f8ceac7810d1681 (patch)
tree55dbfc59771d5ea7a707c38ec6e95603df4d838e /Makefile.am
parent1dd5bf256839184e634eac4b913b0868b8a29358 (diff)
downloadlibgtop-561becc92ef167760e3c13ad2f8ceac7810d1681.tar.gz
`make distcheck' cleanups - Hey, it really works, guys !
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a532aa23..03689bdb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
## Process this file with automake to produce Makefile.in.
+if EXAMPLES
examples_SUBDIRS = examples
+else
+examples_SUBDIRS =
+endif
if GUILE
guile_SUBDIRS = guile
@@ -12,11 +16,13 @@ endif
SUBDIRS = po intl support macros include sysdeps lib src \
$(examples_SUBDIRS)
-DIST_SUBDIRS = po intl macros include sysdeps src lib guile examples
+DIST_SUBDIRS = po intl support macros include sysdeps src lib guile examples
include_HEADERS = glibtop.h
-EXTRA_DIST = autogen.sh libgtop.spec copyright.txt libgtopConf.sh.in
+EXTRA_DIST = autogen.sh libgtop.spec copyright.txt libgtopConf.sh.in \
+ LIBGTOP-VERSION features.def perl/Makefile.PL.in perl/perl.awk \
+ perl/MANIFEST perl/Changes
release:
$(MAKE) dist distdir=$(PACKAGE)$(VERSION)