summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-01-01 20:56:53 +0000
committerMartin Baulig <martin@src.gnome.org>2000-01-01 20:56:53 +0000
commit75ed7287d1e4f4db9226b65d72f81f17eba7d684 (patch)
treecdc4e3d0cebb451a0e1e9fbb9419cf0877e57c9c /Makefile.am
parent8797d185873c0eed6cb0990bc8d4a7c0e915bb0f (diff)
downloadlibgtop-75ed7287d1e4f4db9226b65d72f81f17eba7d684.tar.gz
New directory. New directory. New directory.
2000-01-01 Martin Baulig <martin@home-of-linux.org> * backends/: New directory. * backends/server/: New directory. * backends/sysdeps/: New directory. * include/glibtop/backend.h: New file. * include/glibtop/call-vector.h.in: New file. Template file for `call-vector.h'. * include/glibtop/call-vector.pl: New file. Creates 'call-vector.h' from `call-vector.h.in'. * include/glibtop/errors.h (GLIBTOP_ERROR_NO_SUCH_BACKEND): New error constant. (GLIBTOP_ERROR_NOT_IMPLEMENTED): New error constant. * include/glibtop/limits.h (GLIBTOP_BACKEND_NAME_LEN): New constant. * glibtop-server-private.h (glibtop_server_private): Added `GSList *backend_list' and removed `input', `output', `socket' and `pid'. * lib/command.c: Removed. Moved to `backends/server/'. * lib/read.c: Removed. Moved to `backends/server/'. * lib/read_data.c: Removed. Moved to `backends/server/'. * lib/write.c: Removed. Moved to `backends/server/'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 82a4fc3e..3c6657ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,8 +4,8 @@ if BUILD_GNOME_SUPPORT
support = support
endif
-SUBDIRS = po intl $(support) macros misc include sysdeps lib src doc \
- scripts
+SUBDIRS = po intl $(support) macros misc include sysdeps backends lib \
+ src doc scripts
include_HEADERS = glibtop.h
configincludedir = $(pkglibdir)/include