summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2011-11-02 15:18:20 -0400
committerRobert Roth <robert.roth.off@gmail.com>2015-01-03 15:32:56 +0200
commit3f8f65386e2e88257eca0a0a91c6b3f42132c019 (patch)
tree621b29351f0b1ca70a75e7abe244282e56286f71 /configure.ac
parent30d29e624bba41073841be11feca1fd8a07c5103 (diff)
downloadlibgtop-3f8f65386e2e88257eca0a0a91c6b3f42132c019.tar.gz
Make some APIs that return struct introspectable
In order to do this, we need to define some boxed types. So we need to add a new dependency, GObject, to GTop. https://bugzilla.gnome.org/show_bug.cgi?id=663265
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bc6f88f2..3fe868ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,8 +91,9 @@ GNOME_LIBGTOP_SYSDEPS
GNOME_LIBGTOP_TYPES
GLIB_REQUIRED=2.6.0
+GOBJECT_REQUIRED=2.26.0
-PKG_CHECK_MODULES(GLIB, glib-2.0 >= $GLIB_REQUIRED)
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GOBJECT_REQUIRED)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)