summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1998-12-09 21:19:44 +0000
committerMartin Baulig <martin@src.gnome.org>1998-12-09 21:19:44 +0000
commit3daeda730783dffba93fdba8cadf352645136cd1 (patch)
tree1278f1b4315539baaad3990b0117454990d5da52 /configure.in
parent9e41d36684e8547f82118a256c98039ce5568f16 (diff)
downloadlibgtop-3daeda730783dffba93fdba8cadf352645136cd1.tar.gz
We need to define LIBSUPPORT and SUPPORTINCS under all circumstances as it
1998-12-09 Martin Baulig <martin@home-of-linux.org> * configure.in: We need to define LIBSUPPORT and SUPPORTINCS under all circumstances as it is in gnome-libs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 6 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 956e7e0f..94e2da3e 100644
--- a/configure.in
+++ b/configure.in
@@ -234,16 +234,12 @@ dnl Debugging
AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],AC_DEFINE(LIBGTOP_ENABLE_DEBUG),)
AC_ARG_ENABLE(fatal-warnings, [ --enable-fatal-warnings make all warnings fatal [debug=no]],AC_DEFINE(LIBGTOP_FATAL_WARNINGS),)
-LIBSUPPORT=
-SUPPORTINCS=
-if test "$need_gnome_support" = yes; then
- if test "x$gnome_found" = xyes ; then
- LIBSUPPORT="$GNOME_LIBDIR -lgnomesupport"
- SUPPORTINCS="$GNOME_INCLUDEDIR"
- else
- LIBSUPPORT='$(top_builddir)/support/libgnomesupport.la'
- SUPPORTINCS='-DNEED_GNOMESUPPORT_H -I$(top_builddir)/support -I$(top_srcdir)/support'
- fi
+if test "x$gnome_found" = xyes ; then
+ LIBSUPPORT="$GNOME_LIBDIR -lgnomesupport"
+ SUPPORTINCS="$GNOME_INCLUDEDIR"
+else
+ LIBSUPPORT='$(top_builddir)/support/libgnomesupport.la'
+ SUPPORTINCS='-DNEED_GNOMESUPPORT_H -I$(top_builddir)/support -I$(top_srcdir)/support'
fi
dnl Some ugly hack; if '-lgnomesupport' is part of $GNOME_LIBS,