summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-01-16 00:48:08 +0000
committerMartin Baulig <martin@src.gnome.org>2000-01-16 00:48:08 +0000
commit992e06495266de37c0ffefdd51e633fef7aa54df (patch)
tree98fd3afa89c5a994b898778772b867b44057e3f5 /configure.in
parent26ff5dbd798786038111d3d00b74892233427bfb (diff)
downloadlibgtop-992e06495266de37c0ffefdd51e633fef7aa54df.tar.gz
We now use `@LIBGTOP_PACKAGE@' as the translation domain so installed
2000-01-16 Martin Baulig <martin@home-of-linux.org> We now use `@LIBGTOP_PACKAGE@' as the translation domain so installed `libgtop-1.1.mo' files won't conflict with the ones from LibGTop 1.0 and you can keep both versions installed. * po/Makefile.in.in.in: New file. This is a modified version of the usual `Makefile.in.in' which is created by gettextize; we copy this over `Makefile.in.in' in autogen.sh after gettextize'ing. * autogen.sh: Copy `po/Makefile.in.in.in' over `po/Makefile.in.in' after running `macros/autogen.sh'. * configure.in (LIBGTOP_PACKAGE): AC_SUBST and AC_DEFINE this. * include/glibtop/global.h (_): Use `LIBGTOP_PACKAGE' as our translation domain. 2000-01-16 Martin Baulig <martin@home-of-linux.org> * LIBGTOP-VERSION (LIBGTOP_VERSION_SUFFIX): Added this so you can have your tarballs called `libgtop-1.x.y-snap.tar.gz' or whatever. This only affects the `VERSION' variable and thus how the resulting tarball will be called, but not `LIBGTOP_VERSION_CODE' etc. * Makefile.am: Make `aclocal.m4' also depend on `LIBGTOP-VERSION' when in maintainer-mode.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d132654c..83fecbf7 100644
--- a/configure.in
+++ b/configure.in
@@ -33,6 +33,10 @@ AC_SUBST(LIBGTOP_BINARY_AGE)
AC_SUBST(LIBGTOP_SERVER_VERSION)
AC_SUBST(LIBGTOP_VERSION)
AC_SUBST(LIBGTOP_VERSION_CODE)
+AC_SUBST(LIBGTOP_VERSION_SUFFIX)
+
+AC_SUBST(LIBGTOP_PACKAGE)
+AC_DEFINE_UNQUOTED(LIBGTOP_PACKAGE, "$LIBGTOP_PACKAGE")
# libtool versioning
LT_RELEASE=$LIBGTOP_MAJOR_VERSION.$LIBGTOP_MINOR_VERSION