summaryrefslogtreecommitdiff
path: root/sysdeps/linux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/linux/Makefile.am')
-rw-r--r--sysdeps/linux/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysdeps/linux/Makefile.am b/sysdeps/linux/Makefile.am
index 6b94337b..6776cfbf 100644
--- a/sysdeps/linux/Makefile.am
+++ b/sysdeps/linux/Makefile.am
@@ -1,6 +1,6 @@
INCLUDES = @INCLUDES@
-noinst_LTLIBRARIES = libgtop_sysdeps-2.0.la
+noinst_LTLIBRARIES = libgtop_sysdeps-2.0.la libgtop_sysdeps_suid-2.0.la
libgtop_sysdeps_2_0_la_SOURCES = open.c close.c cpu.c mem.c swap.c \
uptime.c loadavg.c shm_limits.c msg_limits.c \
@@ -18,3 +18,7 @@ libgtopinclude_HEADERS = glibtop_server.h glibtop_machine.h
libgtopincludedir = $(includedir)/libgtop-2.0
noinst_HEADERS = glibtop_private.h
+
+
+libgtop_sysdeps_suid_2_0_la_SOURCES = suid.c
+libgtop_sysdeps_suid_2_0_la_LDFLAGS = $(LT_VERSION_INFO)