summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
deleted file mode 100644
index 1ccf14a..0000000
--- a/data/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-
-SUBDIRS =
-
-if ENABLE_GLADE_CATALOG
-SUBDIRS += glade
-endif
-
-libgweatherdtddir = $(pkgdatadir)
-libgweatherdtd_DATA = locations.dtd
-
-libgweatherlocationsdir = $(pkgdatadir)
-libgweatherlocations_DATA = Locations.xml
-
-### Locations.xml rebuild
-rebuild-locations: locationdb.sqlite update-locations.py
- $(AM_V_GEN)($(srcdir)/update-locations.py > Locations.xml.new && mv Locations.xml.new Locations.xml) || rm -f Locations.xml.new
-
-locationdb.sqlite: build-locationdb.pl major-cities.txt sources/nsd_cccc.txt sources/POP_PLACES.txt sources/US_CONCISE.txt sources/geonames_dd_dms_date_*.txt city-fixups.pl station-fixups.pl
- $(AM_V_GEN)$(srcdir)/build-locationdb.pl
-
-check:
- xmllint --valid --path "$(srcdir)" --noout $(builddir)/Locations.xml
- $(srcdir)/check-timezones.sh $(builddir)/Locations.xml
-
-@INTLTOOL_XML_NOMERGE_RULE@
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gweather-3.0.pc
-
-EXTRA_DIST = \
- gweather-3.0.pc.in \
- gweather-3.0-uninstalled.pc.in \
- Locations.xml.in \
- $(libgweatherdtd_DATA) \
- check-timezones.sh \
- README \
- README.timezones
-
-CLEANFILES = $(libgweatherlocations_DATA)
-
--include $(top_srcdir)/git.mk