summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 17 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e9ead09..b347490 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,6 +207,11 @@ AC_ARG_ENABLE(qt,
[enable Qt support, (MP3 album art) [[default=auto]]]),,
[enable_qt=auto])
+AC_ARG_WITH(qt-version,
+ AS_HELP_STRING([--with-qt-version=major],
+ [Force specific Qt version [[default=auto]]]),,
+ [with_qt_version=auto])
+
selected_for_media_art="no (disabled)"
##################################################################
@@ -218,14 +223,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
fi
if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
- PKG_CHECK_MODULES(QT5,
- [Qt5Gui >= $QT5_REQUIRED],
- [have_qt5=yes],
- [have_qt5=no])
- PKG_CHECK_MODULES(QT4,
- [QtGui >= $QT4_REQUIRED],
- [have_qt4=yes],
- [have_qt4=no])
+ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
+ PKG_CHECK_MODULES(QT5,
+ [Qt5Gui >= $QT5_REQUIRED],
+ [have_qt5=yes],
+ [have_qt5=no])
+ fi
+ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
+ PKG_CHECK_MODULES(QT4,
+ [QtGui >= $QT4_REQUIRED],
+ [have_qt4=yes],
+ [have_qt4=no])
+ fi
if test "x$have_qt5" = "xyes"; then
BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"