summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2016-06-15 17:59:28 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2016-06-16 15:01:13 +0200
commit7880b6c31ad2a4bcf6a8b0308e6a3d50ae53c302 (patch)
tree3c21ce5c15a82866e3898e90c89a372b4fc0b3aa /configure.ac
parentc3f6d8d6f764fdc379d8efffb9916ac58dad6f22 (diff)
downloadlibrest-7880b6c31ad2a4bcf6a8b0308e6a3d50ae53c302.tar.gz
build: Set API version to 1.0
This will change the installed library name from librest-0.7.so to librest-1.0.so as well as the name of the installed .pc file. In short, API and ABI are going to be broken. As the subsequent commits are going to remove deprecated symbols, and change the public API, this is actually desired. Note that older librest versions should be parallel installable with the newer ones.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 334f76d..043eb54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,8 +20,8 @@ AM_INIT_AUTOMAKE([1.11 foreign -Wno-portability no-define dist-xz])
AM_SILENT_RULES([yes])
-API_MAJOR=0
-API_MINOR=7
+API_MAJOR=1
+API_MINOR=0
AC_SUBST([API_VERSION],[$API_MAJOR.$API_MINOR])
AC_SUBST([API_VERSION_AM],[$API_MAJOR\_$API_MINOR])
AC_DEFINE_UNQUOTED(API_VERSION, [$API_VERSION], [API version])