summaryrefslogtreecommitdiff
path: root/rest/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2011-09-03 17:01:13 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2011-09-05 12:22:12 +0100
commit3a25e5627a856972f399a8f0d1e57b7fbc4d252b (patch)
tree58d3d3ce29cff3db8e07dceb914f17cabe56021a /rest/Makefile.am
parentb8eecfc131619a2c5752e1644f3df011b45ef4b4 (diff)
downloadlibrest-3a25e5627a856972f399a8f0d1e57b7fbc4d252b.tar.gz
build: Make libtool generate DLLs on windows
libtool needs -no-undefined to generate DLLs on windows. As that flag can't hurt (on the contrary) for other platforms, just add it to the LDFLAGS.
Diffstat (limited to 'rest/Makefile.am')
-rw-r--r--rest/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/rest/Makefile.am b/rest/Makefile.am
index bf5a5f4..7fa860b 100644
--- a/rest/Makefile.am
+++ b/rest/Makefile.am
@@ -39,6 +39,7 @@ librest_@API_VERSION@_la_CFLAGS = $(GLIB_CFLAGS) $(GTHREAD_CFLAGS) \
$(SOUP_CFLAGS) $(SOUP_GNOME_CFLAGS) \
$(XML_CFLAGS) $(GCOV_CFLAGS) \
-I$(top_srcdir) -Wall -DG_LOG_DOMAIN=\"Rest\"
+librest_@API_VERSION@_la_LDFLAGS = -no-undefined
librest_@API_VERSION@_la_LIBADD = $(GLIB_LIBS) $(GTHREAD_LIBS) \
$(SOUP_LIBS) $(SOUP_GNOME_LIBS) $(XML_LIBS) \
$(GCOV_LDFLAGS)