summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2023-01-15 23:30:17 +0100
committerNiels De Graef <nielsdegraef@gmail.com>2023-01-15 23:31:49 +0100
commit4c98a9cd6b16a557c7c6ae24d938ff1ed88bc1ff (patch)
tree0d8bfa3fd2a0532c38efb796b252fc23548df9e1 /meson.build
parent33a4de59a2a3357cea5bd339489340a9c615024d (diff)
downloadlibsecret-4c98a9cd6b16a557c7c6ae24d938ff1ed88bc1ff.tar.gz
meson: Make default test setup with D-Busnielsdg/meson-dbus-test-setup
This makes sure that our tests run within their own D-Bus session (which is a requirement most of the time) As a result, we can get rid of a few workarounds in our CI to setup such a session.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 81b4d20..97bea7d 100644
--- a/meson.build
+++ b/meson.build
@@ -75,6 +75,12 @@ configure_file(output: 'config.h', configuration: conf)
test_env = environment()
test_env.set('abs_top_builddir', meson.build_root())
+# Most tests require a D-Bus session
+add_test_setup('headless',
+ exe_wrapper: find_program('dbus-run-session'),
+ is_default: true,
+)
+
# Subfolders
subdir('po')
subdir('egg')