summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-03-15 16:19:24 +0100
committerLubomir Rintel <lkundrak@v3.sk>2017-03-19 21:06:17 +0100
commit569bf45135b2be6e0c1de49aee134b29ee6df29e (patch)
treef38f8c37cd44b1e29c6b77b3cfa1feac0f5a8397 /Makefile.am
parent0168d1b979dcab4761950fed2b2a5b78ace3798f (diff)
downloadnetwork-manager-applet-569bf45135b2be6e0c1de49aee134b29ee6df29e.tar.gz
cert-chooser: refactor to delegate file/pkcs11 operations from NMACertChooserlr/pkcs11
Previously, NMACertChooser::constructor() would re-inject the actual type based on the flags property, thus, instead of creating an instance of type NMACertChooser, it would create an NMAFileCertChooser or NMAPkcs11CertChooser. Don't do that. Don't delegate using inheritence and NMACertChooserClass, instead delegate using a vtable structure. Also, hide the actual implementation of NMACertChooser and NMACertChooserClass from public headers. This means, the classes cannot be subclassed, but that is something that is not planned to be supported (at least for the moment). Co-authored-by: Lubomir Rintel <lkundrak@v3.sk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 63b76059..8d923c54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -497,14 +497,13 @@ libnma_c_real = \
src/libnma/nma-file-cert-chooser.c
libnma_h_priv_real = \
- src/libnma/nma-file-cert-chooser.h
+ src/libnma/nma-cert-chooser-private.h
if WITH_GCR
libnma_h_priv_real += \
src/libnma/nma-pkcs11-token-login-dialog.h \
src/libnma/nma-pkcs11-cert-chooser-dialog.h \
- src/libnma/nma-cert-chooser-button.h \
- src/libnma/nma-pkcs11-cert-chooser.h
+ src/libnma/nma-cert-chooser-button.h
libnma_c_real += \
src/libnma/nma-pkcs11-token-login-dialog.c \
@@ -879,11 +878,10 @@ CFILE_GLOB = $(top_srcdir)/src/libnma/*.c
IGNORE_HFILES = \
nma-resources.h \
nma-version.h \
- nma-file-cert-chooser.h \
+ nma-cert-chooser-private.h \
nma-pkcs11-token-login-dialog.h \
nma-pkcs11-cert-chooser-dialog.h \
- nma-cert-chooser-button.h \
- nma-pkcs11-cert-chooser.h
+ nma-cert-chooser-button.h
mkdb_ignore_c_files = \
nma-resources.c \