summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-02-24 18:39:33 +0100
committerLubomir Rintel <lkundrak@v3.sk>2017-03-19 21:06:16 +0100
commit2644d631afd072f66878799e75c5aa1947510c7a (patch)
tree5ec9b49ee7a6a02080bfb391e30bc3a3c16203a4 /Makefile.am
parent6b1bb3052f0d5cb7e40e7916fd737a3b263995ee (diff)
downloadnetwork-manager-applet-2644d631afd072f66878799e75c5aa1947510c7a.tar.gz
libnma: add certificate chooser button
Allows choosing a PKCS#11 token to select a certificate or a key from, optionally selecting one from a file system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c95afc39..23117b70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -502,11 +502,13 @@ libnma_h_priv_real = \
if WITH_GCR
libnma_h_priv_real += \
src/libnma/nma-pkcs11-token-login-dialog.h \
- src/libnma/nma-pkcs11-cert-chooser-dialog.h
+ src/libnma/nma-pkcs11-cert-chooser-dialog.h \
+ src/libnma/nma-cert-chooser-button.h
libnma_c_real += \
src/libnma/nma-pkcs11-token-login-dialog.c \
- src/libnma/nma-pkcs11-cert-chooser-dialog.c
+ src/libnma/nma-pkcs11-cert-chooser-dialog.c \
+ src/libnma/nma-cert-chooser-button.c
endif
src_libnma_libnmadir = $(includedir)/libnma
@@ -876,13 +878,15 @@ IGNORE_HFILES = \
nma-version.h \
nma-file-cert-chooser.h \
nma-pkcs11-token-login-dialog.h \
- nma-pkcs11-cert-chooser-dialog.h
+ nma-pkcs11-cert-chooser-dialog.h \
+ nma-cert-chooser-button.h
mkdb_ignore_c_files = \
nma-resources.c \
nma-file-cert-chooser.c \
nma-pkcs11-token-login-dialog.c \
- nma-pkcs11-cert-chooser-dialog.c
+ nma-pkcs11-cert-chooser-dialog.c \
+ nma-cert-chooser-button.c
MKDB_OPTIONS = --ignore-files "$(IGNORE_HFILES) $(mkdb_ignore_c_files)"