summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-02-19 13:14:52 +0000
committerLubomir Rintel <lkundrak@v3.sk>2017-03-19 21:06:16 +0100
commit5d0be8d56744b858d5158abdc63311ebb270df6c (patch)
tree655f4ce1e4e863c521c811e6062beb34f57232b0 /Makefile.am
parentd370e12c77f89de1a68baf0415d1441cf371ed10 (diff)
downloadnetwork-manager-applet-5d0be8d56744b858d5158abdc63311ebb270df6c.tar.gz
build: optionally build with the GCR support
This will be useful for the PKCS#11 token support. Unfortunatelly, GCR API is declared subject to change despite being in active use and not having changed in years. This is not a problem -- if GCR ever deprecates this API, chances are it will provide a certificate chooser too and we'll be just able to drop ours. It doesn't seem like happening anytime soon. Let's do an extensive check of how good the available GCR version is and disable it if it's not good enough. We'll provide a sensible fallback anyway.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index fe3c7188..4c5895ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,8 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-introspection \
--enable-more-warnings=error \
--with-wwan \
- --with-team
+ --with-team \
+ --with-gcr
man_MANS =
@@ -528,13 +529,15 @@ src_libnma_libnma_la_CFLAGS = \
"-I$(srcdir)/src/libnma" \
$(GTK_CFLAGS) \
$(LIBNM_CFLAGS) \
- $(GUDEV_CFLAGS)
+ $(GUDEV_CFLAGS) \
+ $(GCR_CFLAGS)
src_libnma_libnma_la_LIBADD = \
src/wireless-security/libwireless-security-libnm.la \
$(GTK_LIBS) \
$(LIBNM_LIBS) \
- $(GUDEV_LIBS)
+ $(GUDEV_LIBS) \
+ $(GCR_LIBS)
EXTRA_src_libnma_libnma_la_DEPENDENCIES = src/libnma/libnma.ver