summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2012-05-16 13:53:16 -0400
committerDan Winship <danw@gnome.org>2012-06-20 08:58:27 -0400
commit96ffc8809165235b17170989a1d1b5ada79ca5fb (patch)
tree5bfba6f2e891b5559ea5f76f3e19962356da4ea4 /Makefile.am
parent0d116154fb1e85e6a9551f48e76efdf3ac510373 (diff)
downloadnetwork-manager-applet-96ffc8809165235b17170989a1d1b5ada79ca5fb.tar.gz
applet: port to GSettings
Port from GConf to GSettings, and install a gsettings-data-convert .convert file to migrate old GConf settings over. GConf is now only required if building the migration tool. https://bugzilla.gnome.org/show_bug.cgi?id=662767
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 10 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 319066dd..6bdfb0d2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+include $(GLIB_MAKEFILE)
+
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = src icons po
@@ -21,31 +23,24 @@ desktop_in_files = nm-connection-editor.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
-schemasdir = @GCONF_SCHEMA_FILE_DIR@
-schemas_in_files = nm-applet.schemas.in
-schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
-@INTLTOOL_SCHEMAS_RULE@
+schema_in_files = org.gnome.nm-applet.gschema.xml.in
+gsettingsschema_DATA = $(schema_in_files:.xml.in=.xml)
+@INTLTOOL_XML_NOMERGE_RULE@
+convertdir=$(datadir)/GConf/gsettings
+convert_DATA=nm-applet.convert
DISTCHECK_CONFIGURE_FLAGS = --enable-more-warnings=yes
EXTRA_DIST += \
- $(schemas_in_files) \
+ $(schema_in_files) \
+ $(convert_DATA) \
$(autostart_in_files) \
$(desktop_in_files)
CLEANFILES = \
$(autostart_DATA) \
$(desktop_DATA) \
- $(schemas_DATA)
+ $(gsettingsschema_DATA)
DISTCLEANFILES = intltool-extract intltool-merge intltool-update
-
-install-data-local:
-if GCONF_SCHEMAS_INSTALL
- if test -z "$(DESTDIR)" ; then \
- for p in $(schemas_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/$$p >&1 > /dev/null; \
- done \
- fi
-endif