summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-09 17:11:01 +0100
committerThomas Haller <thaller@redhat.com>2017-02-09 18:23:21 +0100
commita26da4cfaa7a51168f426bc7d726d517a630b003 (patch)
treeadcd0400d515e9e0e4e04f31d8b9ae2399c49417 /Makefile.am
parent52af60920f569fd7c7eefaa9d3c000c050da71be (diff)
downloadnetwork-manager-applet-a26da4cfaa7a51168f426bc7d726d517a630b003.tar.gz
build: add linker version script to hide symbols in nm-applet/nm-connection-editor
The binary should not export any symbols unless explicitly white-listed. This also allows the linker to drop symbols (provided we link with LTO or --gc-sections).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b2e0642..9d622814 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -663,6 +663,12 @@ src_connection_editor_nm_connection_editor_LDADD = \
$(src_connection_editor_nm_connection_editor_OBJECTS): $(connection_editor_h_gen)
+EXTRA_src_connection_editor_nm_connection_editor_DEPENDENCIES = linker-script-binary.ver
+
+src_connection_editor_nm_connection_editor_LDFLAGS = \
+ -Wl,--version-script="$(srcdir)/linker-script-binary.ver"
+
+
EXTRA_DIST += \
src/connection-editor/ce-ip4-routes.ui \
src/connection-editor/ce-ip6-routes.ui \
@@ -783,6 +789,12 @@ src_nm_applet_LDADD = \
$(src_nm_applet_OBJECTS): $(nm_applet_h_gen)
+EXTRA_src_nm_applet_DEPENDENCIES = linker-script-binary.ver
+
+src_nm_applet_LDFLAGS = \
+ -Wl,--version-script="$(srcdir)/linker-script-binary.ver"
+
+
EXTRA_DIST += \
src/8021x.ui \
src/gsm-unlock.ui \
@@ -818,6 +830,7 @@ check-local: $(check_local)
TESTS += $(check_programs)
EXTRA_DIST += \
+ linker-script-binary.ver \
CONTRIBUTING \
intltool-extract.in \
intltool-merge.in \