summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2022-10-04 11:15:19 +0200
committerLubomir Rintel <lkundrak@v3.sk>2022-10-04 12:49:08 +0200
commit971732aec871c103a6d0d12f4a49a7f0f2e53cbc (patch)
tree0d2cc7f680e4117ab76da50d615f7e89392f048a /meson.build
parent2724ffa34527f68fcdd37bc64254c05a3af43ef0 (diff)
downloadnetwork-manager-applet-971732aec871c103a6d0d12f4a49a7f0f2e53cbc.tar.gz
applet: replace libnotify with GNotificationlr/no-libnotify
The libnotify's notify_notification_show() does a blocking D-Bus call. In fact, one fine gentleman's nm-applet got stuck for many seconds because the bus activation aparatus in his computer was not properly greased. Let's do away with this absolute monstrosity of a library by using the desktop notification API provided by GLib since 2.40. It's simpler, fully asynchronous and in addition to freedesktop notification API it can interface with Gtk and Flatpak portal one.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index babc6de2..1052d3f2 100644
--- a/meson.build
+++ b/meson.build
@@ -104,7 +104,7 @@ add_project_link_arguments(common_ldflags, language: 'c')
linker_script_ver = join_paths(meson.source_root(), 'linker-script-binary.ver')
-gio_dep = dependency('gio-2.0', version: '>= 2.38')
+gio_dep = dependency('gio-2.0', version: '>= 2.40')
gmodule_export_dep = dependency('gmodule-export-2.0')
libsecret_dep = dependency('libsecret-1', version: '>= 0.18')
libnma_dep = dependency('libnma', version: '>= 1.8.27')
@@ -125,11 +125,6 @@ gtk_dep = declare_dependency(
# Check for gudev
gudev_dep = dependency('gudev-1.0', version: '>= 147')
-# Check for libnotify >= 0.7
-libnotify_dep = dependency('libnotify', version: '>= 0.4.3')
-config_h.set10('HAVE_LIBNOTIFY_07', libnotify_dep.found() and libnotify_dep.version().version_compare('>= 0.7'),
- description: 'Define if you have libnotify 0.7 or later')
-
# API documentation
nm_req_version = '>= 1.7'
@@ -140,8 +135,8 @@ deps = [
]
cflags = [
- '-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_38',
- '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_38',
+ '-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_40',
+ '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40',
'-DNM_VERSION_MIN_REQUIRED=NM_VERSION_1_16',
'-DNM_VERSION_MAX_ALLOWED=NM_VERSION_1_16',
'-DNMA_VERSION_MIN_REQUIRED=NMA_VERSION_1_8_28',