summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1f969d74..bce4be42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -545,9 +545,19 @@ src/libnma/nma-resources.h: src/libnma/nma.gresource.xml
src/libnma/nma-resources.c: src/libnma/nma.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/src/libnma --generate-dependencies $(srcdir)/src/libnma/nma.gresource.xml)
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $< --target=$@ --sourcedir=$(srcdir)/src/libnma --generate-source --internal
+src/libnma-gtk4/nma-resources.c: src/libnma/nma.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/src/libnma/nma.gresource.xml |sed "s,^,$(builddir)/src/libnma-gtk4/,")
+ @mkdir -p $(builddir)/src/libnma-gtk4
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $< --target=$@ --sourcedir=$(builddir)/src/libnma-gtk4 --generate-source --internal
+
+
+src/libnma-gtk4/%.ui: src/libnma/%.ui
+ @mkdir -p $(builddir)/src/libnma-gtk4
+ gtk4-builder-tool simplify --3to4 $< >$@
+
CLEANFILES += \
$(libnma_h_priv_gen) \
- $(libnma_c_gen)
+ $(libnma_c_gen) \
+ $(libnma_gtk4_c_gen)
libnma_h_priv_gen = \
src/libnma/nma-resources.h
@@ -555,6 +565,9 @@ libnma_h_priv_gen = \
libnma_c_gen = \
src/libnma/nma-resources.c
+libnma_gtk4_c_gen = \
+ src/libnma-gtk4/nma-resources.c
+
libnma_h_pub = \
src/libnma/nma-version.h \
src/libnma/nma-wifi-dialog.h \
@@ -806,7 +819,7 @@ endif
nodist_src_libnma_libnma_gtk4_la_SOURCES = \
$(libnma_h_priv_gen) \
- $(libnma_c_gen)
+ $(libnma_gtk4_c_gen)
src_libnma_libnma_gtk4_la_CFLAGS = \
-DICONDIR=\""$(datadir)/icons"\" \