summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2007-04-03 23:27:33 +0000
committerBastien Nocera <hadess@src.gnome.org>2007-04-03 23:27:33 +0000
commitc6872d0c8dd03a5cca345586c647225e5157a155 (patch)
treef18a9b3dc4d3eb3ad1f1df52f777bd72601181c1 /Makefile.am
parentca2cd82a9aef40c5c315b5d29351b9cf23cdc08a (diff)
downloadtotem-c6872d0c8dd03a5cca345586c647225e5157a155.tar.gz
Turn Totem into a TotemObject, remove calling the screensaver directly,
2007-04-04 Bastien Nocera <hadess@hadess.net> * Makefile.am: * configure.in: * data/Makefile.am: * data/plugins.glade: * data/totem-ui.xml: * data/totem.schemas.in: * src/Makefile.am: * src/plugins/*: * src/totem-menu.c: (totem_plugins_window_delete_cb), (totem_plugins_response_cb), (plugins_action_callback): * src/totem-object.c: (totem_object_class_init), (totem_object_init), (totem_object_finalize), (totem_object_set_property), (totem_object_get_property): * src/totem-private.h: * src/totem.c: (play_pause_set_label), (totem_action_play), (totem_action_seek), (totem_action_stop), (totem_action_play_pause), (totem_action_pause), (window_state_event_cb), (totem_action_seek_relative), (commit_hide_skip_to), (totem_is_playing), (on_eos_event), (video_widget_create), (main): * src/totem.h: Turn Totem into a TotemObject, remove calling the screensaver directly, and emit property notifies when switching to fullscreen, or playing/stopping playing, Add a plugin system, Move the screensaver handling to a builtin plugin. * src/totem-scrsaver.c: * src/totem-scrsaver.h: Move to... * lib/*: ...here * src/backend/bacon-video-widget-xine.c: (bacon_video_widget_class_init): Some cleanups * src/totem-interface.c: (totem_interface_boldify_label): * src/totem-interface.h: Add totem_interface_boldify_label() * src/totem-uri.c: (totem_dot_dir): * src/totem-uri.h: Add the totem_dot_dir svn path=/trunk/; revision=4190
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ba1bef77b..3109418c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = po data src help
+SUBDIRS = po data lib src help
if ENABLE_BROWSER_PLUGINS
SUBDIRS += browser-plugin