summaryrefslogtreecommitdiff
path: root/browser-plugin/Makefile.am
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2012-11-23 11:34:54 +0900
committerJavier Jardón <jjardon@gnome.org>2012-12-10 03:09:57 +0900
commitde8ec4ad07c48d572ccc8af4f347a37afa22f9f5 (patch)
tree32eced4af60447e3c2e9ec6bc821d6b707b9e38c /browser-plugin/Makefile.am
parentec1f7869da72be6c7f16feef37c20e73db11c7ea (diff)
downloadtotem-de8ec4ad07c48d572ccc8af4f347a37afa22f9f5.tar.gz
Use g_cclosure_marshal_generic() instead custom marshallers
Diffstat (limited to 'browser-plugin/Makefile.am')
-rw-r--r--browser-plugin/Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/browser-plugin/Makefile.am b/browser-plugin/Makefile.am
index 52bcd139d..60798d660 100644
--- a/browser-plugin/Makefile.am
+++ b/browser-plugin/Makefile.am
@@ -47,19 +47,6 @@ plugin_ldflags = \
-no-undefined \
$(AM_LDFLAGS)
-# Marshaller
-MARSHAL_FILES = \
- marshal.h \
- marshal.c
-
-marshal.h: marshal.list
- $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=totempluginviewer_marshal --internal --header $< > $@)
-marshal.c: marshal.list marshal.h
- $(AM_V_GEN)($(GLIB_GENMARSHAL) --prefix=totempluginviewer_marshal --internal --body --header $< > $@)
-
-CLEANFILES = $(MARSHAL_FILES)
-EXTRA_DIST += marshal.list
-
# The Glow button test program
noinst_PROGRAMS = test-glow-button
@@ -112,7 +99,7 @@ totem_plugin_viewer_LDFLAGS = -export-dynamic
totem-plugin-viewer-interface.h: org_gnome_totem_PluginViewer.xml
$(DBUS_BIND) --prefix=totem_embedded --mode=glib-server $< > $@
-CLEANFILES += totem-plugin-viewer-interface.h
+CLEANFILES = totem-plugin-viewer-interface.h
EXTRA_DIST += org_gnome_totem_PluginViewer.xml
# Totem GMP Plugin